Products
  
  
  Crash Magic Online
  
  Intersection Magic
  
  Map Magic
  
  Knowledge Base
  
  
  
  Contact Us
  
  Meeting
  
  Shop
  
  Login
  

 

Knowledge Base Article:CMO320 


Registration keys moved to client area: Select login on the left menu bar.

Knowldegebase:
Search home page  

Export Coordinate Data from Crash Magic for Import to ArcMap

Article created: Jul 25 2019, updated: Jul 25 2019

Background:  This article describes how to export coordinate data from Crash Magic for import into ESRI's ArcMap software.


Status:  Info - "how to" article
Keywords:  
Categories:   *Data* *Mapping* *Related software*

Explanation:
Crash data with coordinates may be exported from Crash Magic and imported into ArcMap. This allows interacting with crash data in the ArcMap interface, including the ability to use the Map Magic 2 for ArcMap add-in. Map Magic 2 for ArcMap exposes Crash Magic functionality within the ArcMap interface so you can select crash data in a variety of ways to create Crash Magic studies and reports.


Solution:
There are two steps to this procedure:
  • Export crash data with coordinates from Crash Magic.
  • Import crash data with coordinates into ArcMap and create a selectable feature class.

Export Crash Data with Coordinates from Crash Magic

  1. Create an All Data or Date Range study in Crash Magic. Select your start and end dates.
  2. Create a listing report. Click on the Field List button, and create a new field list containing your fields of interest. At a minimum, the Case Id, Latitude (Y Coordinate) and Longitude (X Coordinate) fields must be included. Select the new field list for your listing report.
  3. Click the Export button at the bottom of the report.


    In the "Export Study" dialog, select your new field list containing coordinate fields.

    You have two options for export format:
    • CSV. Recommended if your Case Id field has non-numeric characters, or is strictly numeric with no leading zeroes.
    • XLS. Recommended if your Case Id field has numeric characters with any leading zeroes. (Note: ArcMap will trim off any leading zeroes during import of a CSV formatted file). If you choose the XLS format, you may need to open and save in Microsoft Excel before importing to ArcMap, to clear any read-only flags on the file.
    Save the file.

Import Crash Data with Coordinates into ArcMap

(Note: These steps are for ArcMap 10.3.1. Other versions may have minor differences. For the most up-to-date import steps from ESRI, please see http://desktop.arcgis.com/en/arcmap/latest/map/working-with-layers/adding-x-y-coordinate-data-as-a-layer.htm and select your version of ArcMap. )
  1. Open ArcMap. Click the Add Data button (or File > Add Data > Add Data...). Select the CSV or XLS file you saved from Crash Magic export process.
  2. The data has been added in the Table of Contents. Right click on the CSV or XLS, and select "Display XY Data...".
  3. Select your X (Longitude) and Y (Latitude) fields from your data. If the coordinate system is not selected, click the "Edit..." button, and select the correct coordinate system for your data. If your data is "standard" latitude and longitude, you can search "4326" to select "WGS 1984" as your geographic coordinate system. Click "OK" to set your coordinate system, then "OK" on the "Display XY Data" dialog. (You may get a warning that the table does not have an ObjectID. This will be handled in the next step.)
  4. You will now have an "Events" layer added to your Table of Contents. Right click the "Events" layer, then select Data > "Export Data...". Select "All features" and the same coordinate system as the layer's source data. Select an output file: a shape file or a geodatabase feature class. Click "OK". Add the exported data to the map as a layer.
  5. The exported crash data points are now selectable as features. You can now remove the CSV or XLS layer and the "Events" layer from the Table of Contents.

October 23, 2019 3:51AM

© 1999-2019 Pd' Programming, Inc - Lafayette, CO USA